Timeouts being experienced when testing the fibre service.
Incident Report for Chorus NZ APIs
Resolved
This issues has been resolved. Chorus will continue to monitor the situation
Posted Jul 02, 2019 - 13:21 NZST
Monitoring
The changes made last night were successful. The teams will continue to monitor the situation and provide further updates as they come to hand.
Posted Jun 26, 2019 - 08:37 NZST
Update
Please be advised that there are two changes planned for tonight (an outage notifcation will be posted shortly) Chorus will be adding addition virtual CPU’s to one of our back end systems. To do this an outage is required which will impact the line test api, including Tech & Check mate when testing the fibre service.

We are also implementing some policy caching and rate limiting changes to balance protecting the back-end system that the api uses. Further updates to come as we continue to monitor the issue.
Posted Jun 25, 2019 - 16:21 NZST
Investigating
Today we once again saw Impact to our Testing capability. Technical teams are continuing investigations to attempt to isolate root cause. Impacts are most noticeable between 13:00 and 17:00. Further updates to follow as they become available
Posted Jun 24, 2019 - 16:07 NZST
Update
Chorus has made a number of changes to increase the back end capacity that has been identified as the main cause to the timeout issues. At this stage the results of the changes are looking promising and we will continuing monitoring.
Posted Jun 20, 2019 - 10:53 NZST
Monitoring
The back end system changes and it's restart was successfully, however the issues experienced occurred under high CPU load. For the purposes of this incident Chorus will continue to monitor.
Posted Jun 14, 2019 - 18:38 NZST
Identified
Chorus has indentified an issue with a back-end system that is experiencing high CPU usage.
Posted Jun 14, 2019 - 16:36 NZST
This incident affected: Line Test API v1 ((Copper Services)) and Chorus Websites (Tech Mate (Fibre Services), Check Mate (Fibre Testing)).