Chorus Unplanned ICT Event Notification: DC13981332

Incident Report for Chorus NZ | API

Resolved

Clearance at 21:00:
All jobs have been processed manually and all data is up-to-date.

Orders are now being processed as per BAU.

No further updates.
Posted Sep 18, 2025 - 21:43 NZST

Update

Update as at 17:00:

The jobs that failed process correctly overnight are being pushed through manually, and will be processed by this evening.

The automated process that has been affected is not being run overnight tonight due to patching on a related server; the next run for this process will be tomorrow night (Friday the 19th).

Technical teams are also continuing their investigations.

Next update as soon as available.
Posted Sep 18, 2025 - 17:09 NZST

Update

Update as at 11:10:

The address issue has now been resolved, however the backend scheduling process did not complete successfully overnight last night.
Technical teams are continuing their investigations.
Posted Sep 18, 2025 - 11:11 NZST

Update

The impacted addresses have now been corrected (duplicate addresses have been removed), and the backend scheduling process needs to run again overnight tonight to confirm it is running correctly.

This incident will again be put into monitoring status overnight, and an update will be supplied by midday tomorrow (18/09/2025).
Posted Sep 17, 2025 - 22:08 NZST

Update

Update as at 11:45:
The backend process did not complete successfully overnight; the fault is still present. However, the impacted addresses are in the process of being removed later today.

Once this has been completed, technical teams will consider the next steps to implement a permanent fix for this issue.

Next update as soon as available.
Posted Sep 17, 2025 - 11:46 NZST

Identified

Update as at 18:15:

Third-party technical teams have carried out updates on the impacted address records that caused a backend process to fail.

This backend process now needs to run through BAU scheduling, which will happen overnight tonight.

This incident will be put on monitor overnight and an update will be supplied by midday tomorrow (17/09/2025).
Posted Sep 16, 2025 - 20:08 NZST

Update

Update as at 13:20:

Third-party technical teams are continuing to investigate the issue.
Next update as soon as available.
Posted Sep 16, 2025 - 13:20 NZST

Investigating

We are currently experiencing issues with an internal Chorus system since around 21:00, Saturday 13/09/2025:

Fibre Provisioning: Any order which requires the creation of a new address will be experiencing delays. Orders requiring the creation of a new address that has been submitted since 13/09/2025 will not progress.

Fibre Place API will not return any results for new addresses created since 13/09/2025.

Please Note: Orders can still be placed as per BAU.
Posted Sep 16, 2025 - 10:13 NZST
This incident affected: APIs (Fibre - Place API).